Block Earner - Registration issue – Incident details

Registration issue

Resolved
Operational
Started 6 months agoLasted about 2 hours
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are investigating reports from users that you may experience difficulty registering new accounts. We are working to resolve the issue and will update as soon as we have more information.